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Quick Start Procedure

Note: Prior to starting the installation process, go to the KTS Wireless website
(ktswireless.com) and download a copy of the TVBD (TV Band Device) Element Management
System (EMS) software. See Section 4.0 of this manual for detailed instructions on its
installation and operation.

Follow the steps below to install and configure Agility White Space Radio (AWR):

1. Select the location for the AWR. Must be an area free of water intrusion with a
temperature range of -30 to +55 deg C (-22 to 130 deg F). It is always best to use one of
the mounting options shown below to provide good ‘heatsinking’ of the AWR case to a
large metal surface. This will reduce the operating temperature of the AWR and

surrounding equipment within the same enclosure.

L-DIN Flat-DIN Wall (with optional Fan)

See the KTS website for ordering information. Correct mounting is critical to maximizing

AWR performance and reliability.

2. Locate the coaxial cable to the antenna. This should be a good quality, low-loss cable
that is as short as possible. This cable should include an in-line surge arrestor to prevent
lightning strike damage to the radio. The cable should have a BNC (F) connector or an
adapter will be needed. See the KTS Wireless website for ordering information, if one is

needed.




3. Locate the power source. The AWR requires a 9-14 VDC input and draws about 1.5 A
(when transmitting). Power is supplied via the 2.5 mm connector on the side of the unit
(See Figure 1). A power cable pigtail is available (ordered separately) and can be used to
connect the AWR to an existing power supply. Alternately, a separate power supply
with the proper 2.5mm connector can be purchased directly from the supplier or from
KTS Wireless. See the website for ordering information.

4. Connect the power supply cable to the AWR and turn on. Observe that the green power
LED is illuminated. It takes about 7-10 seconds for the AWR to boot-up. After this, only
the green power LED should be on.

TX/RX RF Activity Summary Fault Power
(Blinks amber for (Red for fault) (Grn when Power on)
TX and Grn for RX)

5. Connect a laptop to the AWR as shown in the Figure 2. Double-click on the icon below
to start the EMS software installation process.

TVBD_Installer.jar

6. After the installation process is complete and a valid password is entered, the Device
Info screen will appear (See Figure 3). Contact KTS Wireless to obtain your password.

Section 4.0 of this manual contains the details of using the TVBD Element
Management System (EMS). Jump to Section 4.0 for details on setting up the EMS and
resetting the AWR IP addresses (i.e., changing from the default value). The default IP
address of the AWR is 192.168.1.4. Note: Pressing and holding the recessed Reset
button (See Figure 1) for at least 12 seconds will force the radio back to its default

settings.




- Reset Button (recessed)

LED Indicators
Grn: Power
Red: Sum Fault
Amber/Grn: RF Tx/Rx

Ethernet Port

DC Power In
(9-14VDC/2.5 A)

Antenna Serial Port
(BNC)

Figure 1: AWR Connections
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Figure 2: AWR/EMS Connection
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File Tools Help

= =9 White Spaces Element Manager| | Device Info | jp | RF | white Space | white Space Channels | Registration | Statistics | Tools |
White Space Metwork 1 Network

Device Information Device Status

MAC Address: D0:00:00:00:00:00 Registration Status:

Device Mame:

Channel Request Status:
Device Serial Numkber:

RF Serial Mumber:

Alarm Status:
Digital Board Serial Mumker: VSR I
PA Output
Device Type Synthesizer
Maodle Type: .Spoke = RS5I
Country Code: :US v: Temperature i
Refresh l [ Save l l

Figure 3: TVBD EMS Main Screen

Position Color Function
1 Green Power On
2 Red Summary Fault
3 Green/Amber RF Activity

(Amber = TX; Green=RX)

Table 1: LED Definitions
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Copyright Notice

Copyright 2011, KTS Wireless, Inc, All rights reserved

Operational and Safety Notices

The radio described in this manual transmits RF energy. The concentrated energy from the

RF Exposure

antenna may pose a health hazard. All antennas used with this radio must be installed to
provide a minimum separation from all persons of 90 cm (36 inches). The above separation
distance must be maintained at all times. More information can be obtained from the FCC at
the following website:

http://www.fcc.gov/Bureaus/Engineering Technology/Documents/bulletins/oet65/o0et65.pdf
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FCC Part 15 Notice -
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NOTE: This equipment operates under an experimental license.

Equipment operation currently conforms to the rules for TV band
devices, pursuant to Part 15 of the FCC Rules. These rules are
designed to provide reasonable protection against harmful
interference. This equipment generates, uses and can radiate
radio frequency energy and, if not installed and used in
accordance with the instructions, may cause harmful interference
to radio communications. However, there is no guarantee that




interference will not occur in a particular installation. If this
equipment does cause harmful interference to radio or television
reception, which can be determined by turning the equipment off
and on, the user is encouraged to try to correct the interference
by one or more of the following measures:

- Reorient or relocate the receiving antenna.

- Increase the separation between the equipment and receiver.

- Connect the equipment into an outlet on a circuit different
from that to which the receiver is connected.

- Consult the manufacturer, dealer or an experienced radio/ TV
technician for help.

Safety

This product is specifically intended for professional installation. It is advisable to use the
device only in the normal operating position as described in this guide.

WARNING: This device transmits radio frequency (RF) energy. To comply with FCC
RF exposure requirements, antennas must be installed and operated
with a minimum separation distance of 90 cm from all persons.

WARNING: When the system is operational, avoid standing directly in front of the
antenna. Strong RF fields are present when the transmitter is on. The
antenna must not be deployed in a location where it is possible for
people to stand or walk inadvertently in front of the antenna.

WARNING: The electrical installation must be accomplished in accordance with the
National Electrical Code (NEC), and with any local codes effective at the
time of installation

WARNING: To eliminate risk of electric shock, DO NOT connect/disconnect cables
while units are energized.

WARNING: Safety will be compromised if external quality cables are not used for
connections that will be exposed to the weather.

WARNING: Installation of antennas near power lines is dangerous, and contacting
power lines can be lethal. Select the installation site with safety, as well
as performance, in mind. Make sure there are no power lines
anywhere where possible contact can be made. Carefully check the




distance to any power lines before starting installation. The distance
from the mast or antenna to the nearest power line should be at least
twice the total length of the mast/antenna combination.




1.0 Product Description

The Agility White Space Radio (AWR) shown in Figure 1.1 below is designed to provide a reliable
wireless connection for digital communication in selected TV bands in the 174 — 216 MHz (VHF)
or 470 - 698 MHz (UHF) frequency ranges.

Figure 1.1: Agility White Space Radio (AWR)

The AWR is operated under the control of a FCC-approved TVBD database such as the one
provided by Spectrum Bridge, Inc. Its frequency, power level and many other transmit
parameters cannot be set by the operator. This is done to make sure the AWR does not
interfere with other ‘incumbent’ users in the TV bands.

The unit is housed in an aluminum enclosure which is not weather-tight. Two printed circuit
boards are included: RF and Digital. The RF board is provided in one of two configurations as
outlined below:




VHF Band: 174 to 216 MHz

UHF Band: 470 to 698 MHz

These RF cards provide a common differential baseband 1/Q interface to the Digital board. The
RF board includes transmit, receive, synthesizer and control sections. The transmit section
includes an Intermediate Power Amplifier (IPA), Power Amplifier (PA), Variable Attenuator and
Forward and Reverse Power Detectors. The PA provides up to 1 Watt (30 dBm) of RF output
power at the antenna connector, assuming a 6 dBi antenna gain or less. This transmit power is
reduced dB for dB for antennas with higher gain than 6 dBi. The Variable Attenuator is used by
the Automatic Transmit Power Control (ATPC) system processor to set and maintain the proper
transmitted RF power level. A closed-loop process is used with the Forward Power Detector to
maintain the desired output level under all conditions. The Reverse Power Detector is used to
detect impedance mismatches which may occur with an antenna or cable failure.

The receive section of the RF board includes a Tunable Bandpass Filter (TBPF), Low Noise
Amplifier (LNA) and Variable Attenuator. The TBPF is centered by the control processor about
the radio’s operating frequency and has a 20 MHz passband. The LNA provides gain and a noise
figure of about 4 dB. An Automatic Gain Control (AGC) loop is managed by the control
processor using the Variable Attenuator. A constant level is maintained into the Digital board.

The synthesizer section includes a 20 MHz Frequency Reference which is a Temperature-
Compensated Crystal Oscillator (TCXO) with Stratum 3 frequency stability. This reference is
multiplied up to the desired operating frequency within the Synthesizer. The output is applied
to the Digital Up and Downconverters. This provides direct modulation and demodulation of
the baseband, modulated signal.

The control section includes a processor with on-board memory, analog to digital converters
and general purpose I/0. It also includes a serial port which is used to communicate with the
processor on the Digital board. The processor manages the transmit power control and receive
AGC loops. It also programs the synthesizer to tune to the operating frequency. The memory
contains the processor code along with critical calibration tables which are generated during
manufacturing. These tables provide accurate transmit power setting across the band, receive

power estimation and tunable filter control.

The Digital board provides the user ports, message routing and radio management functions.
The radio provides a standard RJ45 Ethernet port for connection to user devices.




The most common application for the AWR is a ‘star’ network where a single hub site
communicates to a collection or remote or ‘spoke’ sites as shown in Figure 2.1.

| /—r/
L e

Remote
Radios
Hub
Radio Server ﬂ
Router@I _

Figure 2.1: Star Network Configuration

The Hub AWR is typically connected to an omnidirectional antenna via a length of coaxial cable.
The signal transmitted by the Hub AWR is then transmitted in a 360-degree pattern to all
remote sites within a range supported by the configured transmitted power. Each remote site




AWR is typically connected to a directional antenna via a length of coaxial cable. These
antennas are ‘pointed’ toward the Hub to achieve maximum gain.

User devices are connected to the Ethernet RJ45 connector of the AWR. The point-to-
multipoint network shown in Figure 2.1 interconnects the Hub AWR with all remote AWRs over
the air. Media Access Control (MAC) software within the AWR allows all the radios to share the
wireless spectrum on a non-interfering basis.

It is assumed that the user traffic is IP. The Hub AWR performs the polling of all remote AWRs.
This happens automatically and transparently to the user devices connected to the Ethernet
ports. This MAC is referred to as Poll/Select. When a remote AWR receives an IP message over
the Ethernet port it is routed through a Learning Bridge in the AWR. If this bridge determines it
should be transmitted over the air, the AWR buffers the message until the next poll is received
from the Hub AWR and transmits the message.




Electrical

Frequency bands
VHF Band
UHF Band
RF Transmit Power
Noise Figure
Spurious & Harmonic Emissions
Blocking/Selectivity
Data Rates
Channel Bandwidth
Modulation
Frequency Selection

Operating mode

Mechanical
Dimensions
Enclosure material
Weight (wall mount)

Mounting (ordered separately)

174 to 216 MHz

470 to 698 MHz

17 to 30 dBm

4 dB

FCC Part 15 compliant®
60 dB, typical

1.5 0r 3.1 Mb/s

6 MHz

2-FSK, SOQPSK

100 kHz steps

Burst, Time-division duplexing

4" x 5" x1.4”
AL, Black powder coating
4009

L-DIN, Flat-DIN or wall mount (with optional integral
(fan)




Environmental

Operating Temperature Range

Operating Humidity

Power

Input Voltage

Consumption
Transmit
Receive

ldle

* FCC Part 15 certification pending.

-30t055° C

Up to 95%, non-condensing

+9to 14 VDC

1.5A

05A

Specifications are subject to change without notice.




4.0 TVBD Element Management System

Most networks require some level of network management and a White Space Network is no
exception. This document will describe the use of the KTS Wireless TVBD White Space Element

Management System (EMS). This tool is used during radio deployment and also to manage the
network once it is fully operational.

I EMS Application Installation

The EMS Application is a Java based application. The application requires a Windows XP (32-bit)

or newer operating system, but will also run in Linux. The minimum Java Runtime Environment
is 5.0.

The included CD contains a software directory with a file called TVBD_Installer.jar. Double click
on the file to launch the installer. The following installation program will be displayed. Select
Next to continue installation of the Element Manager Program.

&% IzPack - Installation of TVBD Element Manager

™ Welcome to the installation of TVBD Element Manager 1.973!
Q This software is developed by:

- Mario Camchong <m.camchong @spectrumbridge. com >
E, The homepage is at: htip:/fwww.spectrumbridge. com/

[Made with IzPack - http://izpack org)

| et || Qout |




@¥ IzPack - Installation of TVBD Element Manager _||E|E|

@ Please read the following license agreement carefully:

End User License Agreement 2

END-USER LICENSE AGREEMENT FOR THE SPECTRUM BRIDGE WHITE SPACE ELEMENT
MANAGER. IMPORTANT PLEASE READ THE TERMS AND CONDITICNS OF THIS LICENSE
AGREEMENT CAREFULLY BEFCORE CONTINUING WITH THIS PROGRAM INSTALL:
Spectrum Bridge, Incorporatedd€™s End-User License Agreement ("EULA™) is
a legal agreement between you (either an individual or a single entity)
for the Spectrum Bridge White Space Element Manager identified above
which may include associated software components, media, printed
materials, and "online™ or electronic documentation. By installing,
copving, or otherwise using the Spectrum Bridge White Space Element
Manager, vou agree to be bound bv the terms of this EULA. This license
agreement represents the entire agreement concerning the program between
you and Spectrum Bridge

Inc., {referred to as ¥licenser®), and it

o ] o e owm e momm w o o T e e e e - -
supersedes any prior pr tatior

posal, Tepresen i, OT
the parties. If youn do not agree to the term=s of this EULA, do not
in=stall or use the Spectrum Bridge White Space Element Manager. W

(%) I accept the terms of this license agreement.

() I do not accept the terms of this license agreement.

[Made with IzPack - http://izpack org)

[ <3 Previous ]| E> Next |[ & Quit ]

To continue the installation, select the “l accept...” radio button and then Next.




&% IzPack - Installation of TVBD Element Manager |Z||E|E|

[&) select the installation path:
|C:‘Program Files\TVBD Element Manager ” E, Browse...

[Made with IzPack - http://izpack org)

| previous || Bpnext || @aut |

The file installation path is displayed. Click Next to continue.

@ The target directory will be created:

:\Program Files\ TYED Element Manager

£ (a4 |[ Cancel ]

‘The target directory will be created’ message is displayed if this is the first installation of the
EMS application. Select OK to continue the installation.




or IzPack - Installation of TVBD Element Manager

Warning!

@ The directory already exists! Are you sure you want to install here and possibly overwrite existing files?

| Ves [ Mo

{Made with IzPack - hitp:/Vizpack.ong/)

| previous || Bpnext || @aut |

‘The directory already exists’ message is displayed when the EMS application is being
reinstalled or updated. Select ‘Yes’, and then select Next to continue the installation.




@¥ IzPack - Installation of TVBD Element Manager :||§|g|

Select the padks you want to install:
Q Mote: Grayed packs are required.

Description
The baze files

Toial space Required: 1.61MB
A rmilmbl o AT 2D
Available space 47.32GB

{Made with IzPack - hitp:/Vizpack.ong/)

| previous || Bonext || @aut |

Select Next to continue the installation.

&¥ IzPack - Installation of TVBD Element Manager Z §|El

Pack installation progress:

[Finished]

Overall installation progress:

1/1

{Made with IzPack - http:/lizpack.org/)

@revos [ pNext || @aut |

Select Next to continue the installation.




&% IzPack - Installation of TVBD Element Manager |Z||E|E|

(| Setup Shortcuts

Create shortouts in the Start-Menu
Create additional shortcuts on the desktop

Select a Program Group for the Shortouts:

Accessories create shortout for:
Administrative Tools
Amazon

BRE Electronics M0 (%) all users
Broadcom

Brother

CutePDF

Dell ControlPaint

Dell Wireless

Dia

ElkRP ~

||*3

() current user

Spectrum Bridge | [ Default

[Made with IzPack - http://izpack org)

[ -@Previous H @-Next H @Quit ]

Modify the Shortcut preferences as desired and select Next to continue.

&% IzPack - Installation of TVBD Element Manager |Z||E|E|

% Installation has completed successfully.

% An uninstaller program has been created in:
C:\Program Files\TVBD Element Manager \Uninstaller

’ @ Generate an automatic installation script

(Made with |zPack - hitp:/lizpack.org/)

Select Done to complete the installation process.




Once the EMS application has been installed, it can be launched by clicking on the TVBD
Element Manager entry in the Start Menu, or from the icon installed on the desktop.

| anming] - oracle TrtualBox W E: x

Machine Devices Help
—

o =
l:. .,

Maric A. Camct

Internet
Google Chrome
. E-mail
L) Micrnsoft Office Qutl|

3et Program Access and Defaulks

Windows Catalog

Windows Lipdate

J€ L9

TWBD Elerment Manager

@ Accessaries 4

I @ Games 4

@ Microsoft Office »

@ Startup »

ﬁ Internet Explorer
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@ Outlook Express
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@ Symantec Endpoint Protection 4
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i
W2 i i |
L'-._. Microsoft OFfice Wor|
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@ TVED Element Manager Uninstaller
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Shut C




I EMS Application User Guide

The TVBD White Space Element Manager is designed show one or more networks and their
nodes on the left panel and specific details about a selected node on the right panel. Clicking on
the circle next to the network’s name expands the tree view to show its hubs. Clicking the circle
to the left of the hub expands the branch to show the spokes associated with that hub. When
the user clicks on a node name, the application displays information about that node on the
right panel. To change the name or IP of a node click on the node, then select Tools -> Edit
Node. Note: You cannot remove the words Network, Hub or Spoke.

Each tab on the right panel groups specific features of the radio. Clicking the Refresh button on
the bottom refreshes the information about the node and clicking the Save button pushes
changes (any change done to a field) to the node. Most fields in the application can be edited

and saved by clicking the Save button at the bottom of the window unless the fields are grayed
out.

& 1¥BD Element Manager 10l =|
File Toolzs  Help
""" B hite Spaces Element Manager Device Info | ip | RF | white Space | White Space Ghannels | Resistration | Statistics | Toots |
Device Information Device Status
MAC Address: IJD:DD:DD:DD:DD:DD Registration Status:
Device Mame: I I
Channel Request Status:
Device Serial Mumber: I l—
RF Serial Mumber: I
Alarm Status:
Digital Board Serial Mumber: I IVS\"\'R—
IPA Output
Device Type ISynthesizer
Mode Type: IDFS Spoke Vl IRSSI
Country Code: IUS hd l ITemperature
Refresh | Save |
———————

Figure 1 - Main EMS Window




A screenshot of each TV Band Devices Element Manager window is provided in order to make
the descriptions of the manager more meaningful.




| Adding a Network

When the EMS application for the first time, the application will not have any network elements
in the left panel and the installer must ‘build” a network tree by first adding a Network name.
To add a Network to the White Spaces Element Manager, click on Tools -> Add Network.

B 1vBD Element Manager

=] 3
File | Toolz  Help
1 .
""" Mm Device Info | | RF | vnite Space | White Space Channels | Registration | Statistics | Tools |
Add Hulb
Add Spoke Device Information ~Device Status

Edit Macle MAC Address: IJD:DD:DD:DD:DD:DU Registration Status:
R Mo I
& Device Mame: I

Channel Regquest Status:
Device Serial Mumber: I I—

RF Serial Mumker: I
Alarm Status:
Digital Board Serial Mumber: I IVSWR
|Pa output

~Device Type IS\,frlthesizer
Mode Type: IDFS Spoke ¥ l IRSSI
Country Code: Ius vl |Temperature

Refresh | Save |

M
|

Figure 2 - Adding a Network




A window will be displayed to enter a network a name as shown below. Note: You do not need
to add the word “Network” to the name as the application will add this automatically. Multiple
networks can be added to the Element Manager. Once the name has been entered, click the

OK button.

BA TvBD Element Manager e -
File Toolz Help

ihite Spaces Element Manager

=10l =]

Device Info | 1P | RF | hite Space | Whie Space Channsls | Redistration | Stetistios. Tools |

rFirmware

Firmuvare Server: I

CPU Firmacare: |

FPGA Yersion |

HiLinx Upcate | Flazh Update

Add Network | et
@ Enter Metwork Mame Ping | I
: IWhite Spaces One|
Metwark Restart | Reset Board
[0]4 ‘E I Cancel |
—Alarm:

Temperature Threshold: | ta | C

Refresh | Save |

)

Figure 3 - Entering the Network Name

The newly created network will show up as a new branch under the White Spaces Element
Manager (the root of the tree).




| Adding Hub to the Network

A hub can be added to the network by first selecting the appropriate network name and then
clicking on Tools -> Add Hub as shown below:

& 1¥ED Element Manager 10l =|
File | Tools  Help
El: AddMetwork I t b i i i A — e
: o | ement hanager Device Info | 2 | RE | white Space | hite Space Channels | Registration | Statistics | Tools |
Add Spoke r-Device Information Device Status

Eciit Mode MAC Address: IJD:DD:DD:DD:DD:DD Registration Status:
R Mo I
& Device hame: I

Channel Reqguest Status:
Device Serial Mumber: I l—
RF Serial Mumber: |
Alarm Status:

Digital Board Serial Mumber: I IVSWR

P& cutout

Device Type ISynthesizer

Nodle Type: [DFS Spoke | [re=

Country Code: |us vl |Temperature

Refresh | Save |

Figure 4 - Adding a Hub




A window will be displayed to enter a name for the new Hub. Note: You do not need to add the

word “Hub” to the name as the application will add this automatically.

& 1¥BD Element Manager 7l

File Toolz Help

=10l |

=] =5 White Spaces Element Manager
rhite One otk

Add Hub Node

'k Erter Hub Mame

Ilst and Third Street|

ok { I Cancel I

Device Info | 1P | RF | White Space | Whits Space Channels | Registration | Statistics Tooks |

~Firmwvare

Firmwware Server: I

CPU Firmeovare: |

FPGA Version |

¥iLinx Update | Flash Update
~Tool
Fing | I
Metwark Restart I Rezet Board

- Az

Temper sture Threshold: | ta | ek

Refresh | Save |

s

Figure 5 - Entering the Hub Name




When the Hub name has been entered, select the OK button. Another popup window will be
displayed to enter the IP address for the Hub. Select OK to finish adding the new Hub.

T\I'B‘D Element Manager __: B ;lglﬂ

File Toolz Help

White Spaces Element Manager Device o | 1P| RE | hite Space | Wihite Space Channels | Registration | Stetistics | Toos |
ithite Spaces One Networ

rDevice Infarmation “Device Status -

MAC Address: |JD:DD:DD:DD:DD:DD Registration Status:
Device Mame I— |

Channel Regquest Status:
Device Serial Number: | Ii
RF Serial Mumber: |

Alarm Status:
— Digital Board Setial Mumber: | |VSWR
Add IP Address x|

[Pa output
Enter Huk's IP Address

10.20.20.66 e e Syrthesizer
Ok I Cancel | Mode Type: |DFS Spokell IRSSI
Country Code: Ius vl |Temperature

Refresh | Save |

Figure 6 - Entering the Hub IP Address

Once the hub has been added, it will appear under the selected network as a new branch.

Note: The network IP address scheme will be defined by the Network Manager or Installer. The
IP addresses displayed in the screen examples are for reference only.




| Adding a Spoke to a Hub

A spoke can be added by selecting the appropriate hub, and then clicking on

Tools -> Add Spoke. Complete the process by follow the screens just like when adding a hub.

BA TvBD Element Manager
File Toolz Help

=10l =]

Mihite Spaces One Mehwar:
Rl 1=t and Third Street Hub [10

rFirmware
Firmuvare Server: |1 02030109

CPU Firmacare: |58

FPGA Yersion [0x2d

HiLinx Upcate | Flazh Update

Add Spoke Node x|
= -~ Tool
Erter Spoke Mame
Ping | I

|33 Pine|Street

(474 i I Caneel |

Metwark Restart | Reset Board

—Alarm:
Temperature Threshold: |—2D to |62 C

|,| Refresh | Save |

EB %a White Spaces Element Manager Device Info | 1P| RF | White Space | White Space Channels | Registration | Statisties Tools |

Kl

|Done Reading 10,20.30.66

)

Figure 7 - Entering the Spoke Name




A 1¥BD Element Manager o

=10l x|
File Tools Help
= =39 _White Spaces Elemant Manager Device info | 1P| RF | White Space | hite Space Channels | Registration | Statistics Teols |
White Spaces One Netwok
Bl 1t aridl Third Street Hub [10 ~Firmwvare
Firmmvare Server: |1 02030109
CPU Firmeocare: IES
FPGA Yersion [ox2d
XiLinz Updsate | Flazh Update
Add 1P Address x|
~Tool
Erter Spoke's IP Address
i
[i0z030.67] &l [
oK I cancel | Metvweark Restart | Reset Board
- Alarm:
Temperature Threshold: |-20 to |65 51
_‘I Iﬂ Refresh | Save |

Tl
i8S
|Dane Reading 10.20,30.66

Figure 8 - Entering the Spoke IP Address

I Deleting a Node

A node can be deleted at any time by selecting it and then clicking Tools -> Remove Node.
Please note that this feature can remove a complete network including branches within this

network. The same applies to deleting a hub node, which will remove all spokes that talk to that
node.




J| saving the Network Configuration

The whole network layout can be saved by clicking File -> Save Network. Once the network is
saved, every time the application is launched, it will remember the network configuration. The
only way to reset this is by deleting all network nodes and clicking File -> Save Network. A
message in the status bar will indicate a successful action.

& 7vED Element Manager

File Toolz Help

=10l x|

k Device Info | p | RF | white Space | White Space Channels | Registration | Statistics | Toots |
Save Radio Configuration
t Hub [1 & —Devi i —Devi
et o Gl ub [ 5] Device Information Device Statu
: Spoke [10.20.30.57] MAC Address: [00:22:63:00:01 42 Reuistration Status:
Exit Spoke [10.20.30.68]
. INot Registered. Waiting for Connectivity...
Device Mame: IMyHub
Channel Request Status:
Device Serial Mumber:  |334
INot Connected. Waiting for Registration...
RF Serial Mumber: |328
Alarm Status:
~Device Type Btheszer
Node Type: [oFS b~ | Rss
Courtry Code: [ U5 > femperawe
Refresh | Save |

———
[Done Reading 10.20.30.66

s

Figure 9 - Saving the Network Configuration

[l save Radio Configuration

Saving a device configuration acts as a backup for a single device. This feature is particularly
useful when doing firmware upgrades to the devices. To save a radio configuration, select the
device to be backed up and click File -> Save Radio Configuration. Note that this is only possible
when selecting a hub or a spoke. A message in the status bar will indicate if the backup has

been successful.




B Restore Radio Configuration

To restore a backed up radio configuration, select the device to be restored and click

File -> Restore Radio Configuration. A message in the status bar will indicate if the restore has
been successful.

I Device Info Tab

| £| TVBD Element Manager @@&J

File Tools Help

E!-:-—-> White Spaces Element Manager
G4 White Space Netaork 1 Network
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Figure 10 - Device Info Tab

The Device Info tab shows information about the radio that makes it unique.

e The MAC Address is a non-editable field populated with its MAC address.

® The Device Name is the radio name (up to 15 characters). This could match the
name selected on the left pane.

® The RF Serial Number is a non-editable field populated with the serial number of the
radio.

[ )

The CPU Firmware is a non-editable field populated with the current version of the
radio firmware.




® The FPGA Version is a non-editable field populated with the current version of the
FPGA firmware.

e The Temperature is a non-editable field populated with the current temperature of
the radio reported in degrees Celsius.

e The Alarm is a non-editable field that indicates if there is an operational problem on
the radio.

e The Node Type specifies if the radio is a Hub or a Spoke (Remote).

e Country Code is a drop-down list of Countries. US should be selected.

Only the Device Name, Node Type and Country Code fields can be edited and saved to the radio
by clicking the Save button at the bottom of the window.

B ip Tab

The TVBD Radios have two network stacks: one for the Ethernet interface and one for the
wireless interface. This IP tab takes care of the Ethernet IP network configuration.
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Figure 11 - IP Tab

DHCP Mode

e DHCP Mode Checkbox can be used to enable DHCP mode. The DHCP checkbox tells
the device to get an IP network configuration from a DHCP server instead of the




statically configured information. Note that in DHCP mode, the radio doesn’t update
the Firmware Server or the White Space Server addresses.

The Static IP Configuration

e Ethernet IP address displays the IP address used to communicate to the device when

DHCP is not enabled.

The Subnet Mask, Gateway, Broadcast Address and DNS Server address fields are

also displayed and are part of the Static IP Ethernet network configuration when
DHCP mode is not enabled.

All fields on this tab can be saved by clicking the Save button on the bottom right corner.
Changing the Ethernet Address will prompt the user to reboot the device
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Figure 12 — RF Tab

The RF tab allows for configuration of the radio.




The Bit Rate is set accordingly in the dropdown box. Values range from 50 kbps to 2
Mbps.

The Modulation is a non-editable field populated with the modulation used by the
radio.

The Center Frequency is the operating frequency of the radio. The corresponding TV
channel is associated to the frequency.

The Operating Band is a non-editable field populated with the RF board type (VHF or
UHF).

The RSSI is a non-editable field populated with the RSSI as a relative value.

Antenna Gain is a dropdown box to input the antenna gain in %2 dBm increments.
Cable Loss is a dropdown box to input the cable loss in 74 dBm increments.

The Transmit Power is the power level set in dBm. The none-editable box displays
the power level in increments of %4 dBm from 17.0 dBm to 32.0 dBm.

Enable Transmit Power Control checkbox allows dynamic power control.
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Figure 13 - White Space Tab

The White Space tab allows for configuration of the radio.

® The coordinates (Latitude and Longitude) are NAD27 decimal coordinates with a
maximum of 5 decimal places. The location of the radio must be entered here and is
used by the White Space database to return a channel map.

e Preferred Channels: The user can pick 3 channels where it would like the network to
operate. If the 1st choice is not available from the channel map sent from the TV
Bands Database, the radio will try to use the 2nd choice and so on. If the 3rd choice
isn’t available either, the device will pick a channel of its own.

® The Operating Channel is a non-editable field which displays the operating
frequency and TV channel of the radio.

® The Query Interval field is used to set the time in minutes to register the device with
a White Space Database.

e The Authorization Interval field is used to set the time in minutes to disable the radio
if there is no connectivity to a White Space Database.




e Antenna Height is used to enter the height of the antenna in meters.
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Figure 14 - White Space Channels Tab

The White Space Channels tab is used to display the channel list returned by the TV Bands

Database for the specific geographic coordinates entered and saved within the device through

the White Space tab.

The TV Bands Database is the server with which the radio communicates to register and get a

list of available channels for operation.




B Registration Tab

ETVBD Element Manager - =1ol x|

File Tools Help

[=+ =5 _White Spaces Element Manager Device Info | P | RF | white Space | White Space Channels  Registration I Statistics | Tools |

= "L Ast and Third Strest Hub [172.20.1.68] Device Information

FCCID:  |KOOSRADIO Serial Mumber,  [335

Lattucke: [34.27579 Longitude:  [-77.79131

Artenna Height: 10 meters

Cortact Information

owner:  [\Whte Space Radia Inc

Contact name:  [dohn Smith

Address: 1193 Broadband Avenue

City: [esotham City

State.  |W4 W Zip Code: [54321

Courtry: [Unted States of America

Emait [izmit@resradia com

Phone:  |333-545-9595
Registration Statu;

Renister | R

|
|bone Reading 172.20.1.67

Figure 15 - Registration Tab

The registration tab contains a tool to register the device with the White Space TV Bands
Database Service.

Note: Each TVBD must be “Enrolled” before it can access the White Space Database. During
the device enrollment process the client must provide the Manufacturer Name, location
information, contact information, the FCC ID, Model and Serial Number for each device to be
enrolled using the following link:
http://demo.spectrumbridge.com/products-services/whitespaces/DeviceEnrollment.aspx.

e FCCID: This field is automatically populated by the radio.

e Serial Number: This field is automatically populated by the radio.

e |Latitude: This field is automatically populated with the configuration from the White
Space tab.

e Longitude: This field is automatically populated with the configuration from the
White Space tab.

e Owner: The name of the individual or business that owns the device.

e Contact name: Name of the contact person responsible for the device’s operation.

e Address: Address of the contact person.

® Email: Email address of the contact person.




® Phone: Phone number of the contact person.

To register the device, click on the Register button.

I Statistics Tab
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Figure 16 - Statistics Tab

Receive Statistics displays receive packet information handled by the MAC. None of the fields in
this tab are editable, but can be polled by clicking the Get Statics button.

® The Good Packets field displays the count of good received packets.

e The Control Packets field displays the count of received control packets.

® The Raw Packets field displays the count of received Raw packets.

e The Eth Packets field displays the count of received Ethernet packets.

® The Packet Count field displays the total amount of packets received.

e The Header CRC Errors field displays the count of received header CRC errors.

® The CRC Errors field displays the count of received CRC errors.

® The Dropped Packets field displays the count of received packets that were dropped.




The Overrun Errors field displays the count of received overrun errors.
The Too Long Frames field displays the count of received too long frames.
The Delivered Packets field displays the count of successfully delivered packets.

Transmit Statistics displays transmit packet information handled by the MAC. None of the fields

in this tab are editable, but can be polled by clicking the Get Statistics button.

The Good Packets field displays the count of good transmitted packets.

The Control Packets field displays the count of transmitted control packets.

The Raw Packets field displays the count of transmitted Raw packets.

The Eth Packets field displays the count of transmitted Ethernet packets.

The Packet Count field displays the total amount of data packets transmitted.
The Complete Packets field displays the total transmitted packet count including
control packets and data packets (without dropped packets).

The Dropped Packets field displays the count of transmitted packets that were
dropped.

Status displays the Device Temperature and RSSI from the radio. None of the fields in the Status

are editable, but can be polled by clicking the Get Statistics button.




l Tools Tab
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Figure 17 - Tools Tab

The Tools tab contains actions for the radio.

Firmware Server is the IP address of the device used as the firmware server.

CPU Firmware displays current version of firmware running on the digital board.
The Flash Update button will update the CPU firmware using the Firmware server
address.

FPGA Version displays the current version of the FPGA firmware

The XiLinx Update button will update the FPGA firmware using the Firmware Server
address.

Tools: If pressed, the Ping button will ping the IP address in the text field if
reachable.

The Network Restart button will re-initialize the network stack.

The Reset Board button will reboot the whole device (digital and radio board).




e Alarms: Temperature Threshold fields allow for a minimum and maximum operating
temperature to be set in degrees Celsius. If the radio operates beyond these
thresholds, an alarm will be triggered.

The mentioned buttons will take action immediately once pressed.




5.0 Upgrading Software

The software in the AWR can be upgraded in the field to support new features or correct any
problems. This can be done locally through the Ethernet port and remotely over the air. The
radio has two types of software which can be field-upgraded (CPU and FPGA). The CPU code
controls the higher-level functionality within the radio including the MAC, networking layers,
network management and user interfaces. The FPGA code supports the Physical layer.

Software upgrades for both the CPU and FPGA code are provided periodically by KTS wireless.
Users are notified when these become available. Some upgrades may be mandatory to resolve
problems while others may be optional if they include new features. Release notes will be
available for each new version outlining the changes. Some new releases may require
additional fees and/or licensing agreements.

The tools tab is used to change the software within the AWR.
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Figure 18 - Tools Tab

The Tools tab contains actions for the radio.

e Firmware Server is the IP address of the device used as the firmware server.

e CPU Firmware displays current version of firmware running on the digital board.

e The Flash Update button will update the CPU firmware using the Firmware server
address.

® FPGA Version displays the current version of the FPGA firmware

e The XiLinx Update button will update the FPGA firmware using the Firmware Server
address.

® Tools: If pressed, the Ping button will ping the IP address in the text field if
reachable.

® The Network Restart button will re-initialize the network stack.

® The Reset Board button will reboot the whole device (digital and radio board).

e Alarms: Temperature Threshold fields allow for a minimum and maximum operating
temperature to be set in degrees Celsius. If the radio operates beyond these
thresholds, an alarm will be triggered.

The mentioned buttons will take action immediately once pressed.




